This forum is shutting down! Please post new discussions at

Another Habitat Quality Question

Hello - I ran the Habitat Quality model using the sample data and it produced a binary habitat quality output raster.  Is this correct?  See screen capture. I was expecting to see something more continuous between 0 and 1. I didn't adjust any parameter settings, etc.



1350 x 700 - 104K


  • swolnyswolny Member, NatCap Staff
    Hi Lee -

    Are the values actually only 0/1, or when you click on each pixel, do they have values in between? Then, how is your symbology set up? Check to see that the Stretch is something like Standard Deviations or Min/Max. Sometimes it defaults to Percent Clip, which can do weird things to the map.

    ~ Stacie
  • Hi and thanks for your quick response. I tried to set it to a number of different symbology settings (classified/stretch) and the result is the same.  The output tif is a 32-bit floating point grid but there are only 2 values (as shown in the attached graph). There are no values in between. 
    451 x 269 - 4K
  • RichRich Administrator, NatCap Staff
    Hi Lee, yes, I get the same result as you do.  Honestly though, I'm not an expert on this model and I'm not sure who would be on staff but I'm willing to dig into the equations and see if that result makes sense.  (I feel like it doesn't make sense).

    More soon!
  • Thanks Rich!
  • Sorry for responding so late. I haven't run the model lately, but I wonder if adjusting the value of the half-saturation constant would help. This is described in the user guide just above "Running the model" in the habitat quality section. We've done this with other datasets and it can make quite a difference.

    @Rich - I seem to recall that in older (ArcTool) versions of InVEST, the sample outputs for this model had a more reasonable spread of values in the output raster, so it might be helpful to compare the new code with the older version?
  • RichRich Administrator, NatCap Staff
    Thanks Nirmal!  Sadly (fortunately?) we don't keep copies of ArcGIS around anymore.  Though we still do have that version of InVEST.  I'll get it on my list to do a whole model refactor whether this thread continues or not.
  • Unfortunately, I have the same problem. Could you please tell me how did you solve it?
  • jdouglassjdouglass Administrator, NatCap Staff

    If you're still having this issue, could you post your question and logfile over on our new forum, ?  We'll be shutting this forum down in the near future.

Sign In or Register to comment.